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1
Introduction
The Dell Desktop Virtualization Solutions (DVS) Simplified 1020 is a Dell PowerEdge T620 system or a PowerEdge R720 
system powered by Citrix VDI-in-a-Box (VIAB) and the hypervisor of your choice:

• Citrix XenServer

• Microsoft Hyper-V

• VMware vSphere ESXi

If the Dell PowerEdge T620 or the PowerEdge R720 systems do not meet your requirements, choose from the following 
supported Dell PowerEdge systems:

PowerEdge Rack 
Systems • PowerEdge R210 II

• PowerEdge R310

• PowerEdge R320

• PowerEdge R415

• PowerEdge R420

• PowerEdge R515

• PowerEdge R520

• PowerEdge R610

• PowerEdge R620

• PowerEdge R715

• PowerEdge R720

• PowerEdge R720xd

• PowerEdge R815

• PowerEdge R820

• PowerEdge R910

PowerEdge 
Tower Systems • PowerEdge T110 II

• PowerEdge T320

• PowerEdge T420

• PowerEdge T620

• PowerEdge T710

PowerEdge 
Modular Systems • PowerEdge M420

• PowerEdge M520

• PowerEdge M610x

• PowerEdge M620

• PowerEdge M820
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• PowerEdge M915

PowerEdge C-
series Systems • PowerEdge C1100

• PowerEdge C2100

• PowerEdge C410x

• PowerEdge C5000

• PowerEdge C5125

• PowerEdge C5220

• PowerEdge C6100

• PowerEdge C6105

• PowerEdge C6145

• PowerEdge C6220

• PowerEdge C8000

• PowerEdge C8000xd

• PowerEdge C8220

• PowerEdge C8220x

NOTE: If you choose from one of the listed systems, the Dell DVS Simplified 1020 software is not factory-installed.

This document provides the necessary steps required to configure the Dell DVS Simplified 1020 appliance.

NOTE: For more information, see the VDI-in-a-Box documentation at support.citrix.com/proddocs/topic/vdi/vdi-
landing-page-52.html.

NOTE: For known issues, see the VDI-in-a-Box documentation at support.citrix.com/proddocs/topic/vdi-52/vdi-
known-issues-52.html.

NOTE: For the latest VDI-in-a-Box updates, see the VDI-in-a-Box documentation at support.citrix.com/cms/kc/vdi-
in-a-box.

The components of the single server solution architecture are illustrated in the following figure:
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Figure 1. Single Server Architecture

System Requirements
Before you proceed with the configuration of Dell DVS Simplified 1020, ensure the following requirements:

• The Dynamic Host Configuration Protocol (DHCP) server is available in your environment.

• The appropriate Windows Volume Licensing is available for your virtual desktops.

For more information on supported virtual desktops and client systems, see the Compatibility Matrix in Dell Desktop 
Virtualization Solutions—Simplified 1020 Solutions Guide at dell.com/support/manuals.

NOTE: It is highly recommended to not install additional services, software, or virtual machines to the hypervisor 
running on your DVS Simplified server.

Contacting Technical Support
Your Dell DVS Simplified Appliance is entitled to Dell service and maintenance. Use the following table to contact the 
Technical Support team for your region:

Country Contact Numbers Extension

United States of America and Canada 1-877-459-7304 N/A

United Kingdom 0844 444 3844 3480157

France 0825 004 686 3250127
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Country Contact Numbers Extension

Germany 069 9792 2064 3122046

Netherlands 0031 206 74 5914 3480158

Austria 82024058256 3122046 (German) 3480108 (English)

Switzerland 0848330092 3122048 (German) 3250121 (French)

Belgium 0248 28 690 3250124 (French) 3480159 (English)

Luxembourg 24871036 3250127

Ireland 1850964270 3480157

Australia 1300 662 370 N/A

New Zealand 800 703 355 N/A

China 800-858-0612
400-886-8617

N/A

Japan 0120 912738 N/A

India 1800 425 2070 N/A

Singapore 1800 395 7935 N/A

Hong Kong 29693187 N/A

Philippines 1800 1601 0061 N/A

Malaysia 1800 880 438 N/A

Vietnam 12060119 N/A

Taiwan 0800 160 1255 N/A

NOTE: To ensure a faster service from your Technical Support representative, have the Service Tag Code for your 
product ready in advance. If you do not have the Service Tag Code, mention your product type as “Flex computing” 
or “part of a Flex solution”.
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2
Setting Up DVS Simplified 1020 
The following steps must be completed to set up the DVS Simplified 1020 before virtual desktops can be deployed:

1. Connecting and configuring physical connections

2. Configuring the hypervisor

3. Configuring the vdiManager

4. Creating a Windows reference virtual machine (VM)

5. Generating a Base Desktop Image

Connecting And Configuring Physical Connections
You can use the following types of network ports to configure your physical connections:

• Gb1 Network Connection—Used to access the vdiManager and virtual desktops.

NOTE: Gb1 network must reach Dynamic Host Configuration Protocol (DHCP) server as it dynamically 
assigns IP addresses to vdiManager and virtual desktops. This IP address is used to access the 
vdiManager after the appliance boots.

• Gb3 Network Connection—Used to manage and access the hypervisor and the host server.

• Integrated Dell Remote Access Controller (iDRAC)—Used for hardware management.

Figure 2. Physical Network Connections

Connect to the server console using one of the following options:

• iDRAC

• KVM switch (not included)
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• Keyboard, mouse, and monitor (not included)

NOTE: You can use the mouse for systems installed with Microsoft Windows Server 2008.

Configuring The Hypervisor

After all the connections are established and the system is powered on, follow the steps for your hypervisor.

Configuring The Hypervisor Using Citrix XenServer

1. Connect to the server console to configure the hypervisor. See the Connecting and Configuring Physical 
Connections section in this document.
After the server boots, the End User License Agreement (EULA) is displayed.

2. Select the checkbox to accept the EULA.

3. Enter the root password for the hypervisor.

NOTE: Save the password to connect to the hypervisor at a later stage.

4. To assign an IP address for the XenServer hypervisor:
a) Select Network and Management Interface.
b) Select the Configure Management interface and enter the required credentials.
c) Select the eth2 Gb3 network connection as the management interface.
d) Select Static.
e) Enter the IP address, netmask, and hostname of the hypervisor.

Configuring The Hypervisor Using Microsoft Hyper-V

1. Connect to the server console to configure the hypervisor. See the Connecting and Configuring Physical 
Connections section in this document.

2. When prompted, set the country, time, and keyboard layout and click Next.

3. Accept the license terms and click the Start button.

4. Press <Ctrl><Alt><Delete> to log on.

5. Select Administrator to log on as the administrator.

NOTE: The kaviza account is a service account created by the VIAB software.

6. Change the administrator password when prompted.

7. Click the Server Manager icon on your desktop notification area to start the Server Manager.

8. In the Server Manager console, navigate to Roles and Hyper-V → Hyper-V Manager and select your server.

9. Under the Action tab, select Virtual Network Manager.

10. In the Virtual Network Manager window, click HVSwitch1.

11. Under Connection type in the right panel of the Virtual Network Manager window, note the NIC port assigned to the 
external network.
This network connection corresponds to Gb1 in the Physical Network Connections diagram.

NOTE: The virtual switch binds to the first physical port. This may not follow the numerical order of the number 
assigned to the port by the operating system. For example, the first physical NIC port (Gb1) may be labeled 
Ethernet #2.

12. Open the Initial Configuration Tasks console and click the Configure networking to open the Network Connections 
window.
The first physical NIC port assigned to the external network is displayed here along with another network 
connection labeled as HVInternalEthernetPort1. Both these connections are applicable for Hyper-V.
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An additional NIC is displayed as connected. This network connection corresponds to Gb3 in the Physical Network 
Connections diagram.

NOTE: It is recommended that you configure this NIC with a static IP address and use it for managing your 
server.

13. In the Initial Configuration Tasks console, click the Activate Windows link and enter your product key.

14. Click Next and proceed through the activation process.

15. If required, add the host server to a domain.
The system reboots to complete this request.

If required, a Windows update can be performed on your server before you configure your grid and start the virtual 
desktops.

NOTE: Ensure that you follow your company policy for applying updates. It is recommended not to allow updates to 
install automatically to prevent unexpected server reboots and issues with VIAB.

Configuring The Hypervisor Using VMware ESXi

1. Connect to the vdiManager server console to configure the hypervisor. See the Connecting and Configuring 
Physical Connections section.

2. Press F2 to customize the system.

3. Enter root for the login name and dvssim11 for the password.

NOTE: The root password is set during the factory installation process. It is highly recommended that you 
change the password using the Configure Password option on the System Customization window.

4. On the System Customization window, select Configure Management Network and press Enter.

5. Use the space bar to select vmnic2 (Gb3 connection) and press Enter.

6. On the Configure Management Network window, select IP Configuration and press Enter.

7. Use the space bar to select Set static IP address… and enter the IP address, subnet mask, and default gateway for 
your hypervisor.

Configuring The vdiManager

Determine The IP Address Of The vdiManager

The IP address of the vdiManager is used to temporarily access the VIAB console until a static IP is configured. The 
procedure varies depending on your hypervisor.

Determining The IP Address Using Citrix XenServer

1. Using the IP address set in the topic Configuring Your Hypervisor, connect to your XenServer using the XenCenter 
client.

NOTE: You can install the XenCenter client by browsing to http://<XenServer IP ADDRESS> or by downloading 
it from the Citrix website.

2. Select the VM vdiManager_Xen.

NOTE: If vdiManager is not started, right-click on the VM and select Start.

3. Select the Networking tab to find the IP address of the vdiManager.
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Determining The IP Address Using Microsoft Hyper-V

1. In the Server Manager console, expand Roles and Hyper-V→ Hyper-V Manager and select your server so that the 
vdiManager VM is displayed under Virtual Machines.

2. Right-click the vdiManager VM and select Start.

3. From the Action tab menu, select Console to access the VM.

NOTE: A message with the IP address for the VIAB console is displayed.

Determining The IP Address Using VMware ESXi

1. Connect to your ESXi hypervisor using vSphere Client or VMware vCenter using the following credentials:

a. IP address: Enter the IP address noted during the procedure Configuring Your Hypervisor.

b. User name: Enter root.

c. Password: Enter your root password. The default is dvssim11.

NOTE: You can install the vSphere client by browsing to http://<IP ADDRESS>, where IP ADDRESS is your 
vSphere hypervisor IP address.

2. If you receive a certificate security warning, select the checkbox next to “Install this certificate…” and click 
Ignore.
An evaluation notice appears until you enter your ESXi license information.

3. Click OK bypass the evaluation for now.

NOTE: You must enter your license information within 60 days or the appliance ceases to function properly.

CAUTION: Do not install a free license key as the APIs required for VIAB to work with the hypervisor close 
and the setup process ends.

4. To enter your license key, click View on the top menu and navigate to Inventory→ Inventory.

5. Click on the IP address of your ESXi host and select the Configuration tab.

6. Click the Licensed Features link under the Software table and then click the Edit... link near the top right of the 
screen.

7. Choose Assign a new license… and enter the license key.

8. Under the Configuration tab, click on the Networking link under the Hardware column to display the virtual switch.

9. Click the Properties... link next to vSwitch0.

NOTE: By default, the VM Network and Management Network are configured to use the same virtual switch 
and physical network adapter. It is recommended that the VM Network be configured to use vmnic0 (Gb1 in 
the Physical Network Connections diagram).

10. In the vSwitch0 Properties window, select VM Network under the Ports tab and click on Remove.

11. Click Yes to confirm.

12. Click Close on the vSwitch0 Properties window.

13. Click the Add Networking… link next to vSwitch0.

14. In the Add Network Wizard window, select Virtual Machine as the connection type and click Next.

15. Select vmnic0 as the virtual switch and click Next.

NOTE: Ensure that the Network Label field is VM Network and the VLAN ID is set to None.

16. Click Next and then Finish.
The Management Network now appears on vSwitch0/vmnic2 and the VM Network on vSwitch1/vmnic0.
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17. In the Inventory view, click on the vdiManager_ESX VM and issue the Power On command indicated by a green 
arrow.
When the vdiManager_ESX VM completes booting, the IP address appears on the Summary tab. If it does not, you 
can determine the address by selecting the Console tab, clicking in the console area, and pressing any key to 
display a message showing the IP address of the VIAB console.

Connecting To The vdiManager

Before attempting to connect to the vdiManager, ensure that:

• Your user account has administrator or root privileges.
• JavaScript and cookies are enabled in your web browser.

Use the following procedure to connect to the vdiManager:

1. Open your web browser and enter the URL http://<IP ADDRESS>/admin to access vdiManager. Use the IP address 
of the vdiManager noted earlier.
A security warning about the website certificate is displayed.

2. Accept the certificate as trusted and continue.
3. Click OK on any additional warnings that are displayed.
4. Log in to the server console using the following credentials:

– User name: vdiadmin
– Password: kaviza

A welcome screen is displayed.

5. Click Get Started.
A window listing the steps and pre-requisites required to generate virtual desktops is displayed.

6. Click Continue on Set up your Hypervisor and VDI-in-a-Box Grid.
VDI-in-a-Box Initial Set up window is displayed.

7. In the Hypervisor section, enter the IP address, user name, and password noted in the Configuring The Hypervisor 
section, to connect to your hypervisor.

NOTE: Enter the IP address for your hypervisor host server and not the vdiManager VM.

8. In the Datastore section, select the local datastore for your hypervisor:

– XenServer: Select Local storage
– Hyper-V: Select C:\ProgramData\Citrix\VIAB
– vSphere ESXi: Select datastore1

9. In the Network Label section, select the Gb1 connection network for your virtual machines:

– XenServer: Select Network 0
– Hyper-V: Select HVSwitch1
– vSphere ESXi: Select VM Network

Configuring A Grid

When setting up a new VDI-in-a-Box environment, create a new grid and associate it with a database containing the 
users and groups who need to access the VIAB VMs. The database can be your Active Directory server or a locally 
stored database called a workgroup.
Join an existing grid when expanding a VIAB environment.
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Creating A New Grid

Ensure the user account has domain administrator privileges.

1. In the Grid section, select Create a new VDI-in-a-Box grid radio button and click Next.

2. Select Active Directory to integrate VDI-in-a-Box desktops to the Active Directory domain or choose VDI-in-a-Box 
workgroup if using VIAB’s local user database instead of Active Directory.

3. Click Next.

NOTE: If Microsoft Active Directory is selected, the details such as IP address, Domain, User name, and 
Password must be provided to access the directory server. If you are using VMware vSphere ESXi using 
vCenter to manage the ESX infrastructure, specify details for vCenter at this step.

After the configuration, a pop-up window is displayed asking if vdiManager has a dedicated IP address.

4. Select Yes or No according to your requirement and click Done.

NOTE: It is recommended to use a static IP address for the VIAB manager.

Joining An Existing Grid

CAUTION: All servers in a grid must use the same type hypervisor. For example, a XenServer hypervisor can only 
join a grid with other XenServer servers.

NOTE: Before adding a new server to the grid, it is recommended that you upgrade the servers in the existing grid 
to the same version hypervisor and VDI-in-a-Box as the new server.

1. In the Grid section, select Join a VDI-in-a-Box server on an existing grid radio button and click Next.

2. On the Configuration page, enter the following:

– IP address of the vdiManager in the existing grid

– the vdiManager console user name

– the vdiManager console password

3. Click Next.
The grid configuration process is complete.

Adjusting The Core Scale Factor On The VIAB Console When Using VMware vSphere ESXi As Hypervisor
Due to the way vSphere APIs report processor cores, a capacity parameter has to be adjusted for the VDI-in-a-Box 
console to properly calculate capacity when vSphere is used as the hypervisor.

NOTE: This procedure is only necessary if using a version of VDI-in-a-Box older than 5.2.

Follow this procedure for VMware vSphere ESXi only.

1. Select the Servers tab in the VIAB console.

2. Click the Desktops link in the row for the server.

3. Click the Adjust button next to the Capacity section.

4. Change the value next to Core Scale Factor to 8.0 and click Save.

5. Click Close on the notification window.

6. Click Close on the Server Status window.

7. Repeat for every server in your grid.
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Creating A Windows Reference VM
After the vdiManager and grid are configured, the next step is to generate a base desktop image, or the first golden 
image, based on an existing Windows reference VM, which can be imported, converted, or created new on your 
hypervisor. Follow the steps to create a new Windows reference VM for your hypervisor.

While creating the Windows reference VM, ensure you meet the following requirements:

• The VM is installed with one of the following operating systems:

– Windows XP Professional edition (32-bit )

– Windows 7 Professional or Enterprise editions (32-bit or 64-bit)

• The local administrator account is enabled on the VM.

• Remote connections is enabled for your users.

• The Remote Desktop Connection (RDP) functionality is enabled.

• The VM has only one network interface card (NIC) and is assigned to Device 0.

• The VM has only one disk image.

• The VM is powered on and operational before you add it to the VDI-in-a-Box grid.

• The VM does not have any snapshots.

• At least 4 GB of space is available on the system.

• The VM is activated using a valid Microsoft Volume Activation key.

• The hypervisor client tools are installed on the VM. For example, if your hypervisor is XenServer, then the 
XenServer tools must be installed on the VM.

• Enable File and Printer Sharing in the firewall settings of the VM to allow remote desktop connections for all 
networks.

• If required, add the VM to a domain.

NOTE: The VM can be a member of a workgroup.

Creating A Windows Reference VM Using Citrix XenServer

1. Use the IP address noted during the procedure Configuring Your Hypervisor to connect to your Citrix XenServer 
using the XenCenter client.

2. Right-click on your server and select New VM. Alternatively, you can click VM on the top menu and select New 
VM.

3. Select the appropriate Windows operating system template and proceed with creating the VM.

Creating A Windows Reference VM Using Microsoft Hyper-V

1. In the Server Manager console, navigate to Roles and Hyper-V→ Hyper-V Manager and select your server.

2. Right-click the name of your server and select the option New→ Virtual Machine. Alternatively, select the Action 
tab and select New→ Virtual Machine.

3. Use the wizard to complete the VM setup.

Creating A Windows Reference VM Using VMware ESXi

1. Connect to your ESXi hypervisor via vSphere Client.

2. In the Inventory view, right-click your server and select New Virtual Machine.
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3. Use the wizard to complete the VM setup.

Generating a Base Desktop Image
Your first VIAB image must be imported from an existing Windows VM running on your hypervisor.
See the section Creating A Windows Reference VM for more information.

To successfully generate a base desktop image:

• Ensure that there is only one DHCP server within range.

• Sufficient DHCP addresses must be available.

• Ensure the DHCP lease time is adjusted for short release cycles.

• The Windows Reference VM must be powered on and running on the hypervisor to begin importing the image.

NOTE: To connect to a Windows Active Directory domain, you must have credentials for an existing 
domain controller.

For detailed steps on importing and editing the image, see support.citrix.com/proddocs/topic/vdi-52/vdi-first-win-
xen.html.

NIC Bonding
You can enable NIC bonding or teaming to implement redundancy. This involves creating two bonds or teams– one for 
the VIAB traffic and one for the hypervisor management. The procedure varies depending on your hypervisor.

NOTE: NIC bonding must be enabled before the VIAB software is configured. If VIAB has already been configured, 
ensure the VIAB grid is shut down and the associated VMs have been powered off before enabling NIC bonding.

NOTE: Configuring the bond/team for load balancing has not been tested at this time and is not described in this 
document.

Enabling NIC Bonding Using Citrix XenServer

1. Using the IP address set in the topic Configuring Your Hypervisor, connect to your XenServer using the XenCenter 
client.

NOTE: You can install the XenCenter client by browsing to http://<XenServer IP ADDRESS> or by downloading 
it from the Citrix website.

2. Click on your server in the left pane and then select the NICs tab.

3. In the Create Bond window, with the NIC 2 and NIC 3 check boxes selected and the Bond Mode set to Active-
passive, click Create.

4. Click the Create bond anyway button in the Create Bond notification window.

5. Click the Networking tab and verify that Bond 2+3 is configured for the management interface at the bottom of the 
window under Management Interfaces.

6. Repeat steps 2 and 3 using NIC 0 and NIC 1 to create the bond.

NOTE: Ensure that you select the Automatically add this network to new virtual machines option for this bond.

7. Click the vdiManager VM in the resource pane and then click the Networking tab. Verify that Bond 0+1 is 
configured as the network interface for the VM.
For more information, see the help section within the XenCenter and Citrix article CTX124421 at support.citrix.com/
article/CTX124421 and article CTX129320 at support.citrix.com/article/CTX129320.
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Enabling NIC Bonding Using Microsoft Windows Server 2008 R2 SP1

NOTE: You cannot create a team using a NIC configured for the Microsoft Hyper-V virtual network. You must first 
create a team using two available adapters and change the Hyper-V virtual network to use that team. Alternatively, 
use an available adapter that will not be part of the team you are creating. You can then create a team using the 
other two adapters.

NOTE: This procedure is for Broadcom NICs only. Do NOT use with or add Intel NICs to the same team as 
Broadcom NICs.

1. Log on to your Windows 2008 R2 SP1 server and browse to the C:\Install\BroadcomAdvanced folder.
2. Launch the BrcmSetup.exe program to add an additional component needed for NIC teaming.
3. Click Next on the InstallShield Wizard, select Modify, and click Next.
4. Click on CIM Provider in the feature list, select the option This feature, and all subfeatures… and click Next.
5. On the Ready to Modify window, click Install and then click Finish when completed.
6. In the notification area of the taskbar, right-click the NIC icon, and select the Launch BACS option. Alternatively, 

you can navigate to Start → All Programs → Broadcom → Broadcom Advanced Control Suite.
7. Select the Go to Team View from the Teams menu in the Broadcom Advanced Control Suite (BACS) application.
8. The Create Team option is displayed under the Teams menu. Select Create Team to proceed.
9. Click Next in the Broadcom Teaming Wizard.
10. Enter a name for the team or accept the default that is displayed and click Next.

The Team Type window is displayed with the Smart Load Balancing and Failover option selected by default

11. Select the Enable HyperV Mode radio button to turn this setting on and click Next.
Ensure that you enable HyperV Mode only on the team used for the Hyper-V virtual network.

12. Add the Broadcom NetXtreme Gigabit Ethernet adapter and “Broadcom NetXtreme Gigabit Ethernet #2” as team 
members and click Next.

13. With the Use the following member as a standby member option selected and the #2 adapter set as standby, click 
Next to continue.

14. In the Configure LiveLink window, select No and click Next.
15. In the Configure VLAN Support window, with the option Skip Manage VLAN selected, click Next.
16. Select the option Commit change to system and Exit the wizardand click Next.

A warning message is displayed.

17. Click Yes.
18. Click the Server Manager icon in the taskbar to open the console. .
19. In the Server Manager console, navigate to Roles and Hyper-V → Hyper-V Manager and click the name of your 

server.
20. Under the Action tab, select Virtual Network Manager.
21. In the Virtual Network Manager window, click HVSwitch1.
22. In the Connection Type panel, change the NIC port assigned to the external network to BASP Virtual Adapter from 

the dropdown menu and click OK.
23. Click Yes to apply network changes.
24. In the BACS application, click on the name of your server in the left panel under Hosts.
25. Repeat steps 7-17 using adapters #3 and #4 in the team and designating adapter #4 as the standby member.
26. Exit the BACS application.

For more information, use the Help tab in the BACS application or see the Using Broadcom Advanced Control Suite 
section in the Broadcom NetXtreme II™ Network Adapter User Guide at dell.com/support/manuals.
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NOTE: Ensure you are using the team with HyperV Mode enabled for the Hyper-V virtual network. For 
example, if you enabled HyperV Mode on the “BASP Virtual Adapter #2”, set this as the external network 
connection for HVSwitch1.

Enabling NIC Bonding Using VMware ESXi

1. Connect to your ESXi hypervisor using vSphere Client or VMware vCenter using the following credentials:

a. IP address: Enter the IP address noted during the procedure Configuring Your Hypervisor

b. User name: Enter root.

c. Password: Enter your root password. The default is dvssim11.

NOTE: You can install the vSphere client by browsing to http://<ESXi IP ADDRESS>.

2. To enter your license key, click View on the top menu and select Inventory→ Inventory.
3. Click on the IP address of your ESXi host and select the Configuration tab.
4. Under the Configuration tab, click on the Networking link under the Hardware column to display the virtual switch.
5. Click the Properties... link next to vSwitch0.
6. Click the Network Adapters tab and click Add.

The Add Adapter Wizard window appears.

7. Select vmnic3 under Unclaimed Adapters and click Next.
8. Ensure vmnic2 and vmnic3 appear under Active Adapters, click Next and then Finish.
9. In the Virtual Switch Properties window, navigate to the Ports tab and select Management Network.
10. Click the Edit button.
11. Click the NIC Teaming tab and change the Load Balancing setting to Use explicit failover order.
12. Click to select vmnic3 under Active Adapters and click the Move Down button to place it under Standby Adapters.
13. Click OK and then click Close on the Switch Properties window.
14. To create a team for the VM Network, repeat steps 4 – 10 above using the properties for vSwitch1 (VM Network) 

and extra adapter vmnic1.
For more information, please see the VMware KB article 1004088 at kb.vmware.com/kb/1004088.
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3
Upgrading Citrix XenServer And VDI-in-a-Box
Upgrading Citrix XenServer
You can upgrade Citrix XenServer from XenCenter by using the Rolling Pool Upgrade wizard in automatic mode. The VDI-
in-a-Box does not support XenServers in a pool but the Rolling Pool Upgradewizard can be used to upgrade stand alone 
servers.You must perform the following steps before upgrading XenServer:

NOTE: You must install the same hotfix updates or upgrade version of XenServer to all hosts in your grid at the 
same time to ensure that all hosts are at the same version level.

NOTE: It is strongly recommended that you backup your servers before upgrading.

1. Download the latest XenServer installation package.

2. Download and install the latest version of XenCenter.

3. Log in to XenCenter and connect to each server in your grid with the local root account.

4. All users must be logged out of their virtual desktops.

5. Copy the new XenServer installation files to an accessible HTTP, NFS, or FTP server.

6. Remove any bootable media from the optical drive on each host.

7. The VDI-in-a-Box grid must be shut down before upgrading. Log in to your VIAB console and perform the following:

a. Enable the maintenance mode on the grid: From the Admin tab, click Grid Maintenance, and then click OK.

b. After all users log out, deactivate all servers in the grid: From the Servers tab, select the server, click 
Deactivate, and then click Confirm. Deactivating a server deletes all desktops, including those in use, and 
immediately shuts down the server so that it no longer provisions desktops. Only the personal desktops 
remain, with a status of "On Hold."

c. Use XenCenter, not the VIAB console, to power off the personal desktop virtual machines if applicable. To 
identify those desktop sessions within the VIAB console, navigate to Desktops →User Sessions and note the 
"On Hold" entries in the Status column.

d. Shut down the vdiManager virtual machines: From the Servers tab in the VIAB console, select the server, 
click Shutdown. Repeat for each server if you have multiple servers in your grid. The servers are now ready 
for the upgrade. User XenCenter to verify that the vdiManager VMs are powered off.

To upgrade XenServer:

1. On the Tools menu within XenCenter, select Rolling Pool Upgrade.
The Rolling Pool Upgrade window is displayed.

2. Read the Before You Start information, and click Next.
The Select Pools information is displayed.
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3. Select the hosts in your grid and click Next.
The Upgrade Mode information is displayed.

4. Select Automatic Mode (recommended mode).

5. Click Run Prechecks.

NOTE: If any prechecks fail, follow the on-screen instructions to resolve them. Click Resolve All for XenCenter 
to automatically resolve all failed prechecks.

6. Click Next.
The Ready to Upgrade information is displayed.

7. In Location of network install files, specify the location of the installation media files and the FTP, HTTP, or NFS 
protocol used to access the files.

NOTE: If you have configured security credentials for the network file source, enter those credentials and not 
the username/password for the XenServer hosts.
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8. Click Test to verify that XenCenter can connect to the installation files.
9. Click Start Upgrade to proceed.

The wizard prompts you if any actions are required during the upgrade of each host. Once completed, a summary is 
displayed.

10. Click Finish to exit the wizard.
11. Use XenCenter to power on all vdiManager virtual machines.
12. When all vdiManagers are running, log on to the vdiManager console and take the grid out of maintenance mode.

From the Admin tab, click Grid Maintenance, and click OK. On the Servers tab, the Recent Tasks and Events section 
should display the message "Server checks out fine" for each server.

13. Activate each server by selecting the server from the Servers tab and then clicking Activate.

Upgrade your images with the latest XenServer tools.

Upgrading VDI-in-a-Box
NOTE: If your current VIAB version is lower than 5.2, you must migrate to 5.2 instead of performing an upgrade. To 
migrate from VDI-in-a-Box 5.0.x or VDI-in-a-Box 5.1.x to VDI-in-a-Box 5.2, follow the procedure provided by Citrix at 
support.citrix.com/proddocs/topic/vdi-52/vdi-migrate-51-to-52.html.

You must perform the following steps to download the VDI-in-a-Box installation package before you upgrade Citrix VDI-
in-a-Box:

1. Go to www.citrix.com and ensure you are logged in to My Citrix.

2. Click Downloads.

3. Click VDI-in-a-Box in the Products list.

4. From the download type list, select Product Software.

5. Click Find. The VDI-in-a-Box product software page appears.

6. Select the latest version of the VIAB software.

7. Scroll down the page until you see the Upgrade link and click to expand it. 

8. From the Upgrade section, click the Download button to download the latest upgrade file. The End-User License 
Agreement (EULA) is displayed.

9. Accept the EULA. The Download Manager window opens.

10. Click Download Now.

11. Navigate to a location to download the tar upgrade file and click Save.

12. Log out of VDI-in-a-Box desktops before performing the upgrade.

NOTE: The upgrade is automatically applied to all servers in the grid. The upgrade installation package cannot be 
rolled back after it is installed.

To upgrade Citrix VDI-in-a-Box:

1. Log in to the vdiManager console.
2. Click Admin → Grid Maintenance.

The Take grid into maintenance mode window is displayed.
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3. Click OK.
A message is displayed at the top of the screen indicating that the grid is in maintenance mode.

4. Click Grid Upgrade on the Admin page.
The Grid Upgrade window is displayed.

5. Click Choose File and select the upgrade file that you had downloaded.

6. Click Submit.
Follow the onscreen instructions to upgrade all the servers in the grid. A progress box displays the upload and 
upgrade progress.

7. Refresh the browser screen if the login window is not displayed and log in to the vdiManager console again.

8. Navigate to Admin → Grid Maintenance → OK to take the grid out of maintenance.
Log in to the vdiManager console again to verify that the grid is not in maintenance mode and it has been upgraded.

NOTE: Click About at the top of the console to verify that the upgrade is complete.

Upgrading the Existing Images
After upgrading VIAB, the existing images need to be updated. On the VIAB console, a caution icon is displayed on the 
status of these images on the Images page. Point your cursor over the caution icon to check for a message indicating if 
the image is out of date. To upgrade the images, use the following procedure:

NOTE: Ensure the user account has domain administrator privileges.

1. On the Images page, select the image to be upgraded.

2. Click on Edit.
A confirmation message stating that a new draft image is about to be created is displayed.

3. Click Confirm.
A new draft image is started.

NOTE: Wait for the status of the new draft image to change to Running before proceeding.

4. In the row for the new draft image, click Edit.
The Specify Administrator Credentials dialog box is displayed.

5. Select whether to provide credentials for an administrator or a local user with administrator privileges.

NOTE: If using a local user account, disable UAC.

6. Type the user name and password and click OK.
The installation of the new Desktop Agent begins and a status page showing the progress is displayed. The Edit 
Image page of the wizard is displayed.

22



7. On the Edit Image page, make any additional edits to the image that you require, such as adding new applications, 
and click Next.

8. Complete the Prepare Image and Test Image pages. For instructions for these steps, see the relevant topics for 
your hypervisor and image operating system at support.citrix.com/proddocs/topic/vdi/vdi-landing-page-51.html.

9. On the Test Image page, click Save.
10. Click Confirm.

The upgraded image is published and ready to be deployed based on your refresh policies.

Refreshing The Desktops
After upgrading to VIAB 5.1, desktops created using the 5.0.x version of VDI-in-a-Box must be replaced with new 
desktops. After upgrading your images, refresh the desktops from the VIAB console:

1. On the Servers page, select the old system and click Deactivate.
2. Click Confirm to remove the old system.
3. On the Servers page, select the new system and click Activate.
4. Click Confirm to activate the new system.
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4
Licensing Information
XenServer Licensing

NOTE: Applying your license for VDI-in-a-Box 5.0.2 and higher automatically upgrades and licenses XenServer 6.0 
and higher to Citrix XenServer for XenDesktop edition, even if you have previously activated a free XenServer 
license.

Click Tools on the XenCenter menu and select License Manager to confirm if your XenServer license has been 
upgraded.

Microsoft Hyper-V Licensing
1. Click the Activate Windows link on the Initial Configuration Tasks console.

2. Enter the license key.

3. Click Next and proceed through the activation process.

The activation screen can also be accessed from Control Panel→ System and Security→ System→ Windows 
activation.

VMware ESXi Licensing
1. Use the vSphere Client to connect to your hypervisor host.

2. Select the View tab at the top of the menu and navigate to Inventory →Inventory.

3. Click on the IP address of your ESXi host and select the Configuration tab.

4. Click on the Licensed Features link under the Software table.

5. Click on the Edit link near the top right corner of the vSphere window.

6. Select Assign a new license… and enter the license key.

Generating A License For VDI-in-a-Box
To get VDI-in-a-Box license from Citrix:

1. Log on to MyCitrix.com using the credentials given by Citrix.

2. Navigate to MyTools → Choose a Toolbox → Manage Licenses .

3. Select Allocate.

4. Select the Citrix VDI-in-a-Box license pertaining to your order and click Continue.

5. In Quantity, enter the quantity of licenses to allocate and click Continue.

6. Click Confirm to complete the license allocation and generate the license.
A message prompts you to download the license file(s).

7. Click OK and download the license file(s).
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Applying A License To VDI-in-a-Box
After receiving the license from Citrix, apply the license to VDI-in-a-Box. Before applying the license, put the grid in 
maintenance mode.

1. Go to Admin Tab → Click Grid Maintenance and click OK.

2. On the Admin page, click Grid Upgrade.
The Grid Upgrade dialog box is displayed.

3. Click Choose File, browse to the upgrade or license file, and click OK.

4. Click Submit.
When the upgrade completes, the server status changes to Success.

5. Log on to vdiManager when prompted.

6. Go to Admin Tab → Click Grid Maintenance and click OK.
After applying the license, take the grid out of maintenance mode.

For more information, see support.citrix.com/proddocs.

KMS Licensing

Windows Activation

VDI-in-a-Box 5.x supports both KMS and MAK Volume Licensing for Windows 7 desktops.
Volume Activation methods were introduced with Windows 7 and do not apply to Windows XP. VIAB only supports 
Volume Licensed versions of Windows XP, which do not require activation with Microsoft. KMS activation is the 
preferred method for most customers that have at least 25 unique Windows activations across both physical and virtual 
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VIAB machines every 30 days. KMS allows for unlimited number of activations, can be easily managed by a KMS host 
and VAMT, and usually requires no change to the golden image.

VIAB 5.1 offers a new setting at the template level to reset the KMS activation timer. Leaving this unchecked implies that 
the image's activation clock is not rearmed during preparation. Checking the box implies that the image activation clock 
is rearmed during preparation, decrementing the activation count. If the image's activation clock is rearmed more than 
three times before the image is activated by KMS, the image cannot be prepared because the generalize step fails. If 
your environment is already using a KMS Host, the only thing an administrator needs to do is ensure the DNS SRV 
records are available to the VDI-in-a-Box virtual desktops. The administrator can also configure the golden image to 
contact a KMS Host manually. For these details and more information on Windows KMS activation, please refer to VDI-
in-a-Box Best Practices for Windows Activation at support.citrix.com/article/CTX134349

Microsoft Office 2010 Activation

Microsoft Office 2010 can be activated using the same KMS Host used by the Windows machines using KMS 
activations. Unlike Windows 7 activations, which require at least 25 requests to be activated, Office 2010 only requires 
five requests to get activated when using KMS. Using KMS for both Microsoft Windows and Microsoft Office typically 
requires no modification of the Office installation. However, it is important to trigger the activation on the golden image 
before publishing it.

Follow the steps below to trigger the activation:

1. Edit and log in to the VDI-in-a-Box golden image.
2. Install Office 2010 and install the updates.
3. Open the Command Prompt and browse to C:\Program Files\Microsoft Office\Office14.

NOTE: For 64-bit machines the path isC:\Program Files (x86)\Microsoft Office\Office14.

4. Specify KMS Host: Enter cscript ospp.vbs /sethst:<KMS_Host>.

Example: cscript ospp.vbs /sethst:kms01.company.com.

5. Trigger MS Office activation: Enter cscript ospp.vbs /act.

6. Confirm licensing status: Enter cscript ospp.vbs /dstatus.

7. Save the golden image.
8. Enable Fast Desktop Refresh for the image.

ViaB 5.1 has this item configured at template level.

9. Log in to a desktop and confirm Office 2010 is activated by confirming the license status as specified in Step 6. 
Optionally, you can also check the activation status by opening any Office 2010 application and navigating to File→ 
Help.

NOTE: For more information, refer to the article VDI-in-a-Box Best Practices for Microsoft Office Activation at 
support.citrix.com/article/CTX134351.
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5
Connecting Dell Wyse Thin Clients To A DVS 
Simplified Environment
The Dell Wyse T10, Z50D, and Z90D7 thin clients are recommended for seamless connectivity to a DVS Simplified virtual 
environment. These thin clients have been tested with VDI-in-a-Box, and are certified for both Citrix Ready and Citrix 
HDX Ready standards. Citrix Ready is a product verification program that allows customers and users to find partner 
products and solutions trusted to enhance Citrix offerings. The Citrix HDX Ready certification is reserved for devices that 
have been verified to work with all Citrix HDX features.

NOTE: This document does not cover detailed system configurations and options for the Dell Wyse thin clients. For 
more information on network setup, see the Administrators Guide that came with the product.

Ensure the following before you proceed with the configuration of Thin Client settings:

• Note the IP address of the vdiManager using the Networking tab on the vdiManager.

• Configure the Dell Wyse thin client to use DHCP or a static IP address.

• The thin client must be able to communicate with the vdiManager over your network.

Configuring The T10 Thin Client
You can configure the T10 Thin Client using one of the following options:

• The Wyse Zero ToolBar (recommended)

• Dynamic Host Configuration Protocol (DHCP)

Configuring The T10 Thin Client Using The Wyse Zero ToolBar

1. Click the Systems Settings icon on the Wyse Zero Toolbar and open the Remote Connections option.
2. Select the Broker Setup tab and configure the following:

a) Select Citrix Xen as broker.
b) In the Broker Server field, enter the URL to access the config.xml file using the IP address of your vdiManager. 

For example: http://172.16.0.135/dt/PNAgent/config.xml
c) Click OK and allow the device to restart when prompted.

After the T10 thin client restarts, a Login dialog box is displayed.
d) Enter the user name, password, and domain, as applicable, for your virtual desktop and click Login.

If you are assigned to more than one desktop template, you can choose the desktop that you want to connect 
to. Else, you are logged in to your assigned desktop.

Configuring The T10 Thin Client Using DHCP

You can configure and use the custom DHCP Scope Option to automate the connection to the vdiManager in case of the 
following conditions:
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• The T10 thin client is configured for DHCP.

• The Windows 2003 or Windows 2008 DHCP server is available.

Configuring The T10 Thin Client Using Windows 2008 DHCP Server

1. Right-click My Computer and select Manage.

2. In the DHCP window, expand your DHCP server option, right-click on IPv4, and click Set Predefined Options.
The Predefined Options and Values window is displayed.

3. Click the Add button.

4. Enter the following details in the Option Type window:

– Name: Enter a name for the server. For example, vdiManager.

– Data type: Enter String
– Code: Enter 181
– Description: Enter a description for the server.

5. Click OK.

6. On the Predefined Options and Values window, scroll down to verify that the new option tag 181 has been added 
and press Cancel to return to the DHCP window.

7. On the left pane, right-click on Scope Options under your scope and select Configure Options…

8. Scroll down and select Option 181.

9. Enter the URL to access the config.xml file using the IP address of your vdiManager. For example: http://
172.16.0.135/dt/PNAgent/config.xml

NOTE: If you have more than one vdiManager in your grid, you can enter URL for each separated by semi-
colons. For example: http://172.16.0.135/dt/PNAgent/config.xml; http://
172.16.0.136/dt/PNAgent/config.xml

10. Click OK.
Your Windows 2008 DHCP server is now configured with option tag 181.

11. Configure the T10 Thin Client for DHCP and restart the device. For more information, see the Wyse ThinOS Getting 
Started Guide that shipped with you system.

Configuring The T10 Thin Client Using Windows 2003 DHCP Server

1. Right-click My Computer and select Manage.

2. In the Computer Management console, expand Services and Applications.

3. Highlight DHCP and click Set Predefined Options.
The Predefined Options and Values window is displayed.

4. Click the Add button.

5. Enter the following details in the Option Type window:

– Name: Enter a name for the server. For example, vdiManager.

– Data type: Enter String
– Code: Enter 181
– Description: Enter a description for the server.

6. Click OK.

7. On the Predefined Options and Values window, scroll down to verify that the new option tag 181 has been added 
and press Cancel to return to the Computer Management console.

8. On the left pane, right-click on Scope Options under your scope and select Configure Options…

9. Scroll down and select Option 181.
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10. Enter the URL to access the config.xml file using the IP address of your vdiManager. For example: http://
172.16.0.135/dt/PNAgent/config.xml

NOTE: If you have more than one vdiManager in your grid, you can enter URL for each separated by semi-
colons. For example: http://172.16.0.135/dt/PNAgent/config.xml; http://
172.16.0.136/dt/PNAgent/config.xml

11. Click OK.
Your Windows 2003 DHCP server is now configured with option tag 181.

12. Configure the T10 Thin Client for DHCP and restart the device. For more information, see the Wyse ThinOS Getting 
Started Guide that shipped with you system.

Configuring The Z50D Thin Client
1. Click the Computer icon on the Wyse Zero Toolbar and launch the Connection Manager application.
2. Click Add.
3. Enter the following details in the Option Type window:

– Connection type: Select BROWSER

– Description: Enter a description for the server, such as VIAB.

– URL: Enter the URL which in this case is http://<ip of your VIAB server>. For example: http://172.16.0.135/

– Auto Connect: Check the box for Auto Connect if required.
4. Click OK.
5. Click on the VIAB browser connection in the Connection Manager application.
6. Click Connect to launch the browser.

The URL opens to a login page for Citrix Receiver.

7. Enter your login credentials for the domain so that VDI-in-a-Box can assign you to a desktop.
8. Save this connection to create a shortcut on the desktop that you can launch later.

Configuring The Z90D7 Thin Client
1. Click the Receiver icon on think client desktop to launch the application.
2. Click I Will Enter the URL Now.
3. Enter the URL which in this case is http://<ip of your VIAB server>. For example: http://172.16.0.135/.
4. Enter the domain or username and password as appropriate for your virtual desktop and click Log On.

You are not required to re-enter the URL during login the next time onward, until you logoff or reboot the thin client.

NOTE: For more information on logging in as an administrator, using the File Based Write Filter Utility to enable 
changes to the system, and to retrieve your settings after reboot of a thin client, see the Wyse WES7 
Administrator’s Guide.
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